blob: 522a4615f027c2250544809e4b13dc498d27433b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils games
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc ppc64 ~sparc x86"
IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
RDEPEND=${DEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc46.patch
}
src_configure() {
egamesconf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
$(use_enable debug) \
$(use_enable opengl)
}
src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
prepgamesdirs
}