blob: 46bd28b65d88f9fd334a44b520afc545145aabcc [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit autotools eutils
PATCH=3989
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
SRC_URI="mirror://gentoo/dosbox-code-0-${PATCH}-dosbox-trunk.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86"
IUSE="alsa debug hardened opengl"
RDEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/glu virtual/opengl )
debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
DEPEND="${RDEPEND}
app-arch/unzip"
S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
PATCHES=(
"${FILESDIR}"/dosbox-0.74-gcc46.patch
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
$(use_enable alsa alsa-midi) \
$(use_enable !hardened dynamic-core) \
$(use_enable !hardened dynamic-x86) \
$(use_enable debug) \
$(use_enable opengl)
}
src_install() {
default
make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
doicon src/dosbox.ico
}