blob: 0d601c0924a0029cd4050e3fcdddb5a104dafd0b [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit autotools
DESCRIPTION="Astrometric and photometric solutions for astronomical images"
HOMEPAGE="http://www.astromatic.net/software/scamp"
SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
SLOT="0"
IUSE="doc plplot threads"
RDEPEND="
sci-astronomy/cdsclient
sci-libs/atlas[lapack,threads=]
sci-libs/fftw:3.0
plplot? ( sci-libs/plplot:= )"
DEPEND="${RDEPEND}"
src_prepare() {
default
local mycblas=atlcblas myclapack=atlclapack
if use threads; then
[[ -e "${EPREFIX}"/usr/$(get_libdir)/libptcblas.so ]] && \
mycblas=ptcblas
[[ -e "${EPREFIX}"/usr/$(get_libdir)/libptclapack.so ]] && \
myclapack=ptclapack
fi
sed -e "s/-lcblas/-l${mycblas}/g" \
-e "s/AC_CHECK_LIB(cblas/AC_CHECK_LIB(${mycblas}/g" \
-e "s|lapack_lib=\"lapack\"|lapack_lib=${myclapack}|" \
-i acx_atlas.m4 || die
sed -e 's|plplotd|plplot|g' -i acx_plplot.m4 || die
eautoreconf
}
src_configure() {
econf \
--with-atlas-incdir="${EPREFIX}/usr/include/atlas" \
$(use_enable plplot) \
$(use_enable threads)
}
src_install () {
default
use doc && dodoc doc/*
}