blob: fbe66fb87862ed6e759587b9eaa3415cb995cd54 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1
DESCRIPTION="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP"
HOMEPAGE="https://pypi.python.org/pypi/meteor-ejson https://github.com/lyschoening/meteor-ejson-python"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64"
IUSE="test"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
nosetests || die
}