blob: 06c3b1ea52ca22db38dba59dbe906f0130a4aba4 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
VIRTUALX_REQUIRED="test"
inherit kde5
DESCRIPTION="Framework for managing menu and toolbar actions in an abstract way"
KEYWORDS="amd64 ~arm x86"
LICENSE="LGPL-2+"
IUSE="attica"
# drop qtgui subslot operator when QT_MINIMAL >= 5.6.0
RDEPEND="
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kglobalaccel)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui '' '' '5=')
$(add_qt_dep qtnetwork 'ssl')
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
attica? ( $(add_frameworks_dep attica) )
"
DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package attica KF5Attica)
)
kde5_src_configure
}