blob: fe089ca5168cc1803b9d13d502f6064561f315ff [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils multilib-minimal
MY_P=SDL2_net-${PV}
DESCRIPTION="Simple Direct Media Layer Network Support Library"
HOMEPAGE="http://www.libsdl.org/projects/SDL_net/index.html"
SRC_URI="http://www.libsdl.org/projects/SDL_net/release/${MY_P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="static-libs"
RDEPEND=">=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]"
DEPEND=${RDEPEND}
S=${WORKDIR}/${MY_P}
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
--disable-gui \
$(use_enable static-libs static)
}
multilib_src_install() {
emake DESTDIR="${D}" install
}
multilib_src_install_all() {
dodoc {CHANGES,README}.txt
prune_libtool_files
}