blob: e3cc4962789085f233121a737fda33c9fc4f5163 [file] [log] [blame]
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit eutils toolchain-funcs
DESCRIPTION="OpenGL visualization for HDAPS data"
HOMEPAGE="http://hdaps.sourceforge.net"
SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="virtual/opengl
media-libs/freeglut"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-as-needed.diff"
}
src_compile() {
emake CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} ${LDFLAGS}" \
|| die "emake failed"
}
src_install() {
dobin ${PN}
}