blob: eefc6df2e3c10680e9503c8de36e30c57f90cfa5 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
MY_PN="Louie"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Signal dispatching mechanism for Python"
HOMEPAGE="https://pypi.python.org/pypi/Louie"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
python_prepare_all() {
sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"
distutils-r1_python_prepare_all
}
python_test() {
nosetests || die "Tests fail with ${EPYTHON}"
}