blob: 71ecbd48236ff7b23e8369f67200f3957c1157e9 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
inherit ruby-fakegem
DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
LICENSE="MIT"
SLOT="3"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/activesupport )"
all_ruby_prepare() {
# Remove bundler and fix one spec that depends on its requires
#rm Gemfile || die
sed -i -e '/[Bb]undler/d' Rakefile || die
sed -e '/pry/ s:^:#:' -i spec/spec_helper.rb || die
# Avoid dependency on rspec-pending_for and its dependencies
sed -i -e '/pending_for/ s:^:#:' \
spec/spec_helper.rb \
spec/hashie/mash_spec.rb \
spec/hashie/extensions/strict_key_access_spec.rb || die
}