blob: 579019e11935432824f81ff713eaf8e9a4759c4e [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit cmake-utils
DESCRIPTION="Common base library for the LXQt desktop environment"
HOMEPAGE="http://lxqt.org/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="GPL-2 LGPL-2.1+"
SLOT="0"
RDEPEND=">=dev-libs/libqtxdg-1.3.0
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
kde-frameworks/kwindowsystem:5[X]
"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
tc-is-gcc && [[ $(gcc-version) < 4.8 ]] && \
die 'The active compiler needs to be gcc 4.8 (or newer)'
fi
}