blob: 3193f8a99a779fb6f752fe0cc95e90fa99d0bcb5 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200511-09">
<title>Lynx: Arbitrary command execution</title>
Lynx is vulnerable to an issue which allows the remote execution of
arbitrary commands.
<product type="ebuild">lynx</product>
<announced>November 13, 2005</announced>
<revised>November 13, 2005: 01</revised>
<package name="www-client/lynx" auto="yes" arch="*">
<unaffected range="ge">2.8.5-r2</unaffected>
<vulnerable range="lt">2.8.5-r2</vulnerable>
Lynx is a fully-featured WWW client for users running
cursor-addressable, character-cell display devices such as vt100
terminals and terminal emulators.
iDefense labs discovered a problem within the feature to execute
local cgi-bin programs via the "lynxcgi:" URI handler. Due to a
configuration error, the default settings allow websites to specify
commands to run as the user running Lynx.
<impact type="normal">
A remote attacker can entice a user to access a malicious HTTP
server, causing Lynx to execute arbitrary commands.
Disable "lynxcgi" links by specifying the following directive in
All Lynx users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-client/lynx-2.8.5-r2&quot;</code>
<uri link="">CVE-2005-2929</uri>
<uri link=";type=vulnerabilities">iDefense Security Advisory 11.11.05</uri>
<metadata tag="requester" timestamp="Fri, 11 Nov 2005 20:17:54 +0000">
<metadata tag="submitter" timestamp="Fri, 11 Nov 2005 21:30:52 +0000">
<metadata tag="bugReady" timestamp="Sun, 13 Nov 2005 17:03:02 +0000">