blob: 5df6f06edbc3cb4f21d0f2dd395857cb242a08e5 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils multilib scons-utils toolchain-funcs subversion
DESCRIPTION="Open source implementation of IF97 steam tables"
HOMEPAGE="http://freesteam.sourceforge.net/"
SRC_URI=""
ESVN_REPO_URI=https://freesteam.svn.sourceforge.net/svnroot/freesteam/trunk
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE=""
RDEPEND="sci-libs/gsl"
DEPEND="${RDEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-flags.patch
"${FILESDIR}"/${PN}-soname-symlinks.patch
epatch_user
}
src_configure() {
myesconsargs=(
INSTALL_PREFIX=/usr
INSTALL_LIB=/usr/$(get_libdir)
INSTALL_ROOT="${D}"
CC="$(tc-getCC)"
SWIG=false
)
mkdir -p "${D}" || die
}
src_compile() {
escons
}
src_install() {
escons install
}