blob: 5f4837bb6104f266be1b74ad6157e4a61093353a [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/kde-base/kreversi/kreversi-4.3.4.ebuild,v 1.3 2010/01/23 03:00:29 abcd Exp $
EAPI="2"
KMNAME="kdegames"
inherit games-ggz kde4-meta
DESCRIPTION="KDE Board Game"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="debug +handbook"
src_prepare() {
# cmake is doing this really weird
sed -i \
-e "s:register_ggz_module:#register_ggz_module:g" \
${PN}/CMakeLists.txt || die "ggz removal failed"
kde4-meta_src_prepare
}
src_install() {
kde4-meta_src_install
# and also we have to prepare the ggz dir
insinto /usr/share/ggz/modules
newins ${PN}/module.dsc ${P}.dsc
}
pkg_postinst() {
kde4-meta_pkg_postinst
games-ggz_pkg_postinst
}
pkg_postrm() {
kde4-meta_pkg_postrm
games-ggz_pkg_postrm
}