blob: 5d885bc1f1a0a8f3e7b943906f243272a52cc476 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
DESCRIPTION="py-bcrypt is an implementation of the OpenBSD Blowfish password hashing algorithm"
HOMEPAGE="https://code.google.com/p/py-bcrypt/"
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD-4"
SLOT="0"
KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
IUSE=""
RDEPEND="!dev-python/bcrypt"
DOCS=( LICENSE README TODO )
python_test() {
distutils_install_for_testing
"${PYTHON}" test/test.py || die "tests failed"
}