blob: d3577c1eaae600162ffbdc675ad11acf6a789d3c [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit xemacs-elisp eutils
MY_PN="gentoo-syntax"
DESCRIPTION="An Emacs mode for editing ebuilds and other Gentoo specific files"
HOMEPAGE="https://www.gentoo.org/proj/en/lisp/emacs/index.xml"
SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.bz2"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
RDEPEND=">=app-editors/xemacs-21.4.20-r5
app-xemacs/sh-script"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_PN}-${PV}"
src_compile() {
${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
-f batch-byte-compile gentoo-syntax.el || die
xemacs-elisp-make-autoload-file *.el || die
}