blob: 44d8fe5806bfcbe9503599cf90d787149b365e17 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 pypy)
inherit eutils distutils-r1
DESCRIPTION="RAML reference implementation in Python"
HOMEPAGE="https://ramlfications.readthedocs.org/ https://pypi.python.org/pypi/ramlfications/"
SRC_URI="https://github.com/spotify/${PN}/releases/download/0.1.9/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/markdown2[${PYTHON_USEDEP}]
dev-python/jsonref[${PYTHON_USEDEP}]
dev-python/click[${PYTHON_USEDEP}]
dev-python/attrs[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/xmltodict[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
)
"