blob: 6aaec3544b63a315d6c7335304ece26c3721515d [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
QT5_MODULE="qtlocation"
inherit qt5-build
DESCRIPTION="Physical position determination library for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm ~hppa ppc64 x86"
fi
IUSE="geoclue qml"
RDEPEND="
~dev-qt/qtcore-${PV}
geoclue? ( ~dev-qt/qtdbus-${PV} )
qml? ( ~dev-qt/qtdeclarative-${PV} )
"
DEPEND="${RDEPEND}"
PDEPEND="
geoclue? ( app-misc/geoclue:0 )
"
QT5_TARGET_SUBDIRS=(
src/positioning
src/plugins/position/positionpoll
)
pkg_setup() {
use geoclue && QT5_TARGET_SUBDIRS+=(src/plugins/position/geoclue)
use qml && QT5_TARGET_SUBDIRS+=(src/imports/positioning)
}