blob: 780a930607dd08875e168c2e5a08fa17a862ddc0 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
KDE_TEST="false"
inherit kde5
DESCRIPTION="Framework for notifying the user of an event"
LICENSE="LGPL-2.1+"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="dbus nls speech X"
RDEPEND="
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kwindowsystem)
$(add_qt_dep qtdbus)
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
media-libs/phonon[qt5]
dbus? ( dev-libs/libdbusmenu-qt[qt5] )
speech? ( $(add_qt_dep qtspeech) )
X? (
$(add_qt_dep qtx11extras)
x11-libs/libX11
x11-libs/libXtst
)
"
DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
X? ( x11-proto/xproto )
"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package dbus DBusMenuQt5)
$(cmake-utils_use_find_package speech Qt5TextToSpeech)
$(cmake-utils_use_find_package X X11)
)
kde5_src_configure
}