blob: 6f3a216976273be61ebc2d8d176e6e2fd058468e [file] [log] [blame]
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild,v 1.2 2008/12/14 16:57:30 ssuominen Exp $
inherit eutils toolchain-funcs
DESCRIPTION="utility for preparing a hibernation partition for APM Suspend-To-Disk"
HOMEPAGE="http://www.procyon.com/~pda/lphdisk/"
SRC_URI="http://www.procyon.com/~pda/lphdisk/${P}.tar.bz2"
LICENSE="Artistic"
SLOT="0"
KEYWORDS="x86"
IUSE=""
DEPEND="sys-libs/lrmi"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_compile() {
tc-export CC
emake || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
}
pkg_postinst() {
ewarn "This package is now using system lrmi library instead of shipped"
ewarn "copy it came with. This package is untested, use at your own risk."
}