blob: 48ac899eecea5db28a7b3e38f9cbf0af317023f5 [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.13.4.ebuild,v 1.1 2010/03/06 22:09:40 ssuominen Exp $
EAPI=2
DESCRIPTION="Classes for threads and monitors, wrapped around the posix thread library"
SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/${PN}/download/${P}.tar.gz"
HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/html/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc"
DEPEND=">=dev-libs/dvutil-1.0.5"
src_prepare() {
sed -i \
-e 's:dvthread doc m4:dvthread m4:' \
Makefile.in || die
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS
if use doc; then
doman doc/man/man3/*.3
dohtml -r doc/html/*
fi
}