blob: 884b314656bf74de83ecb847f9b5bc0fb76c8704 [file] [log] [blame]
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-oci8/ruby-oci8-1.0.3.ebuild,v 1.4 2009/12/20 14:20:34 graaff Exp $
inherit ruby
DESCRIPTION="A Ruby library for Oracle"
HOMEPAGE="http://rubyforge.org/projects/ruby-oci8/"
SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
LICENSE="Ruby"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
USE_RUBY="ruby18 ruby19"
RDEPEND="dev-db/oracle-instantclient-basic
dev-db/oracle-instantclient-sqlplus"
DEPEND="${RDEPEND}"
src_compile() {
emake CONFIG_OPT="--prefix=${D}usr" || die
}
src_install() {
emake DESTDIR="${D}" install || die
}