blob: 391d1503bb7b609fef1e9c3d8f35641c55003be0 [file] [log] [blame]
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/adplug/adplug-2.1.ebuild,v 1.5 2008/09/21 13:38:02 ranger Exp $
inherit eutils
DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
HOMEPAGE="http://adplug.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE="debug"
RDEPEND=">=dev-cpp/libbinio-1.4"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {
econf --disable-dependency-tracking $(use_enable debug)
emake || die "emake failed."
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS BUGS ChangeLog NEWS README TODO
}