| # TODO(sbc): switch to using Pipenv since it seems like that way to go | |
| # these day managing python deps. | |
| # These requirements are only needed for developers who want to run ruff on | |
| # the codebase and generate docs using Sphinx, not for users of emscripten. | |
| # Install with `pip3 install -r requirements-dev.txt` | |
| coverage[toml]==7.15.0 | |
| mypy==2.3.0 | |
| psutil==7.0.0 | |
| ruff==0.16.6 | |
| types-requests==2.32.0.20241016 | |
| unittest-xml-reporting==3.2.0 | |
| deadcode==2.3.1 | |
| vulture==2.14 | |
| # This version is mentioned in `site/source/docs/site/about.rst`. Please keep | |
| # them in sync. We cannot currently update to v8 or v9 due to our python 3.10 | |
| # dependency. | |
| # TODO(sbc): Update sphinx version once we update our min python requirements. | |
| sphinx==7.4.7 | |
| sphinx-design==0.6.1 | |
| sphinxcontrib-jquery==4.0 | |
| shibuya==2026.5.19 | |
| # Needed by tests in test_sockets.py | |
| websockify==0.12.0 | |
| # Needed by tests in test_other.py | |
| meson==1.11.2 |