| <html><body> | |
| <style> | |
| body, h1, h2, h3, div, span, p, pre, a { | |
| margin: 0; | |
| padding: 0; | |
| border: 0; | |
| font-weight: inherit; | |
| font-style: inherit; | |
| font-size: 100%; | |
| font-family: inherit; | |
| vertical-align: baseline; | |
| } | |
| body { | |
| font-size: 13px; | |
| padding: 1em; | |
| } | |
| h1 { | |
| font-size: 26px; | |
| margin-bottom: 1em; | |
| } | |
| h2 { | |
| font-size: 24px; | |
| margin-bottom: 1em; | |
| } | |
| h3 { | |
| font-size: 20px; | |
| margin-bottom: 1em; | |
| margin-top: 1em; | |
| } | |
| pre, code { | |
| line-height: 1.5; | |
| font-family: Monaco, 'DejaVu Sans Mono', 'Bitstream Vera Sans Mono', 'Lucida Console', monospace; | |
| } | |
| pre { | |
| margin-top: 0.5em; | |
| } | |
| h1, h2, h3, p { | |
| font-family: Arial, sans serif; | |
| } | |
| h1, h2, h3 { | |
| border-bottom: solid #CCC 1px; | |
| } | |
| .toc_element { | |
| margin-top: 0.5em; | |
| } | |
| .firstline { | |
| margin-left: 2 em; | |
| } | |
| .method { | |
| margin-top: 1em; | |
| border: solid 1px #CCC; | |
| padding: 1em; | |
| background: #EEE; | |
| } | |
| .details { | |
| font-weight: bold; | |
| font-size: 14px; | |
| } | |
| </style> | |
| <h1><a href="dns_v1beta2.html">Cloud DNS API</a> . <a href="dns_v1beta2.projects.html">projects</a> . <a href="dns_v1beta2.projects.managedZones.html">managedZones</a> . <a href="dns_v1beta2.projects.managedZones.rrsets.html">rrsets</a></h1> | |
| <h2>Instance Methods</h2> | |
| <p class="toc_element"> | |
| <code><a href="#close">close()</a></code></p> | |
| <p class="firstline">Close httplib2 connections.</p> | |
| <p class="toc_element"> | |
| <code><a href="#create">create(project, managedZone, body=None, clientOperationId=None, x__xgafv=None)</a></code></p> | |
| <p class="firstline">Creates a new ResourceRecordSet.</p> | |
| <p class="toc_element"> | |
| <code><a href="#delete">delete(project, managedZone, name, type, clientOperationId=None, x__xgafv=None)</a></code></p> | |
| <p class="firstline">Deletes a previously created ResourceRecordSet.</p> | |
| <p class="toc_element"> | |
| <code><a href="#get">get(project, managedZone, name, type, clientOperationId=None, x__xgafv=None)</a></code></p> | |
| <p class="firstline">Fetches the representation of an existing ResourceRecordSet.</p> | |
| <p class="toc_element"> | |
| <code><a href="#patch">patch(project, managedZone, name, type, body=None, clientOperationId=None, x__xgafv=None)</a></code></p> | |
| <p class="firstline">Applies a partial update to an existing ResourceRecordSet.</p> | |
| <h3>Method Details</h3> | |
| <div class="method"> | |
| <code class="details" id="close">close()</code> | |
| <pre>Close httplib2 connections.</pre> | |
| </div> | |
| <div class="method"> | |
| <code class="details" id="create">create(project, managedZone, body=None, clientOperationId=None, x__xgafv=None)</code> | |
| <pre>Creates a new ResourceRecordSet. | |
| Args: | |
| project: string, Identifies the project addressed by this request. (required) | |
| managedZone: string, Identifies the managed zone addressed by this request. Can be the managed zone name or ID. (required) | |
| body: object, The request body. | |
| The object takes the form of: | |
| { # A unit of data that is returned by the DNS servers. | |
| "kind": "dns#resourceRecordSet", | |
| "name": "A String", # For example, www.example.com. | |
| "rrdatas": [ # As defined in RFC 1035 (section 5) and RFC 1034 (section 3.6.1) -- see examples. | |
| "A String", | |
| ], | |
| "signatureRrdatas": [ # As defined in RFC 4034 (section 3.2). | |
| "A String", | |
| ], | |
| "ttl": 42, # Number of seconds that this ResourceRecordSet can be cached by resolvers. | |
| "type": "A String", # The identifier of a supported record type. See the list of Supported DNS record types. | |
| } | |
| clientOperationId: string, For mutating operation requests only. An optional identifier specified by the client. Must be unique for operation resources in the Operations collection. | |
| x__xgafv: string, V1 error format. | |
| Allowed values | |
| 1 - v1 error format | |
| 2 - v2 error format | |
| Returns: | |
| An object of the form: | |
| { # A unit of data that is returned by the DNS servers. | |
| "kind": "dns#resourceRecordSet", | |
| "name": "A String", # For example, www.example.com. | |
| "rrdatas": [ # As defined in RFC 1035 (section 5) and RFC 1034 (section 3.6.1) -- see examples. | |
| "A String", | |
| ], | |
| "signatureRrdatas": [ # As defined in RFC 4034 (section 3.2). | |
| "A String", | |
| ], | |
| "ttl": 42, # Number of seconds that this ResourceRecordSet can be cached by resolvers. | |
| "type": "A String", # The identifier of a supported record type. See the list of Supported DNS record types. | |
| }</pre> | |
| </div> | |
| <div class="method"> | |
| <code class="details" id="delete">delete(project, managedZone, name, type, clientOperationId=None, x__xgafv=None)</code> | |
| <pre>Deletes a previously created ResourceRecordSet. | |
| Args: | |
| project: string, Identifies the project addressed by this request. (required) | |
| managedZone: string, Identifies the managed zone addressed by this request. Can be the managed zone name or ID. (required) | |
| name: string, Fully qualified domain name. (required) | |
| type: string, RRSet type. (required) | |
| clientOperationId: string, For mutating operation requests only. An optional identifier specified by the client. Must be unique for operation resources in the Operations collection. | |
| x__xgafv: string, V1 error format. | |
| Allowed values | |
| 1 - v1 error format | |
| 2 - v2 error format | |
| </pre> | |
| </div> | |
| <div class="method"> | |
| <code class="details" id="get">get(project, managedZone, name, type, clientOperationId=None, x__xgafv=None)</code> | |
| <pre>Fetches the representation of an existing ResourceRecordSet. | |
| Args: | |
| project: string, Identifies the project addressed by this request. (required) | |
| managedZone: string, Identifies the managed zone addressed by this request. Can be the managed zone name or ID. (required) | |
| name: string, Fully qualified domain name. (required) | |
| type: string, RRSet type. (required) | |
| clientOperationId: string, For mutating operation requests only. An optional identifier specified by the client. Must be unique for operation resources in the Operations collection. | |
| x__xgafv: string, V1 error format. | |
| Allowed values | |
| 1 - v1 error format | |
| 2 - v2 error format | |
| Returns: | |
| An object of the form: | |
| { # A unit of data that is returned by the DNS servers. | |
| "kind": "dns#resourceRecordSet", | |
| "name": "A String", # For example, www.example.com. | |
| "rrdatas": [ # As defined in RFC 1035 (section 5) and RFC 1034 (section 3.6.1) -- see examples. | |
| "A String", | |
| ], | |
| "signatureRrdatas": [ # As defined in RFC 4034 (section 3.2). | |
| "A String", | |
| ], | |
| "ttl": 42, # Number of seconds that this ResourceRecordSet can be cached by resolvers. | |
| "type": "A String", # The identifier of a supported record type. See the list of Supported DNS record types. | |
| }</pre> | |
| </div> | |
| <div class="method"> | |
| <code class="details" id="patch">patch(project, managedZone, name, type, body=None, clientOperationId=None, x__xgafv=None)</code> | |
| <pre>Applies a partial update to an existing ResourceRecordSet. | |
| Args: | |
| project: string, Identifies the project addressed by this request. (required) | |
| managedZone: string, Identifies the managed zone addressed by this request. Can be the managed zone name or ID. (required) | |
| name: string, Fully qualified domain name. (required) | |
| type: string, RRSet type. (required) | |
| body: object, The request body. | |
| The object takes the form of: | |
| { # A unit of data that is returned by the DNS servers. | |
| "kind": "dns#resourceRecordSet", | |
| "name": "A String", # For example, www.example.com. | |
| "rrdatas": [ # As defined in RFC 1035 (section 5) and RFC 1034 (section 3.6.1) -- see examples. | |
| "A String", | |
| ], | |
| "signatureRrdatas": [ # As defined in RFC 4034 (section 3.2). | |
| "A String", | |
| ], | |
| "ttl": 42, # Number of seconds that this ResourceRecordSet can be cached by resolvers. | |
| "type": "A String", # The identifier of a supported record type. See the list of Supported DNS record types. | |
| } | |
| clientOperationId: string, For mutating operation requests only. An optional identifier specified by the client. Must be unique for operation resources in the Operations collection. | |
| x__xgafv: string, V1 error format. | |
| Allowed values | |
| 1 - v1 error format | |
| 2 - v2 error format | |
| Returns: | |
| An object of the form: | |
| { # A unit of data that is returned by the DNS servers. | |
| "kind": "dns#resourceRecordSet", | |
| "name": "A String", # For example, www.example.com. | |
| "rrdatas": [ # As defined in RFC 1035 (section 5) and RFC 1034 (section 3.6.1) -- see examples. | |
| "A String", | |
| ], | |
| "signatureRrdatas": [ # As defined in RFC 4034 (section 3.2). | |
| "A String", | |
| ], | |
| "ttl": 42, # Number of seconds that this ResourceRecordSet can be cached by resolvers. | |
| "type": "A String", # The identifier of a supported record type. See the list of Supported DNS record types. | |
| }</pre> | |
| </div> | |
| </body></html> |